Матвеев Андрей Сергеевич

Microsoft Excel подсчет кол-во повторений в строке

Как подсчитать количество соответствий определенному значению в соседнем столбце. 

Поиск по столбцу и подсчет значений в соседнем столбце

Допустим у нас есть таблица из двух столбцов(A и B),

А 1
Б 1
В 0
Г 1
А 0
Б 0
Г 1
Г 1
Г 0
А 1
В 0
Г 0
Г 1

 

В столбце:

A - буквы (АБВГ)

B - цифры (1 или 0).

 

Необходимо посчитать сколько раз упоминается цифра 1 для определенной буквы например для буквы Г.

Для этого воспользуемся функцией:

=СУММЕСЛИ(A1:B13;"Г";B1:B13)

В результате получим 4.

 

Так же можно воспользоваться следующей функцией:

=СУММПРОИЗВ(--(A1:A13&B1:B13="Г0"))

В результате получим 2.

 

 

Опубликовано:20 Февраль, 2016, Просмотров:1359, Печать
 
© 2019 Все права защищены [ PG.t : 0.01 | DB.q : 5 | DB.t : 0.00 ]